2023/08/13

zhenaifen / 2023-08-13 / 原文

给定一个带整数键值的链表 L,你需要把其中绝对值重复的键值结点删掉。即对每个键值 K,只有第一个绝对值等于 K 的结点被保留。同时,所有被删除的结点须被保存在另一个链表上。例如给定 L 为 21→-15→-15→-7→15,你需要输出去重后的链表 21→-15→-7,还有被删除的链表 -15→15。

输入格式:
输入在第一行给出 L 的第一个结点的地址和一个正整数 N(≤10 
5
 ,为结点总数)。一个结点的地址是非负的 5 位整数,空地址 NULL 用 −1 来表示。

随后 N 行,每行按以下格式描述一个结点:

地址 键值 下一个结点
其中地址是该结点的地址,键值是绝对值不超过10 
4
 的整数,下一个结点是下个结点的地址。

输出格式:
首先输出去重后的链表,然后输出被删除的链表。每个结点占一行,按输入的格式输出。

输入样例:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
输出样例:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1
import java.util.Scanner;
public class Main{
    public static void main(String[] args)
    {
        Scanner sc=new Scanner(System.in);
        int a[]=new int[100001];
        int b[]=new int[100001];
        int c[]=new int[100001];//用于记录当链值是否第一次出现
        int rs1[]=new int[100001];//用于记录原链种的地址
        int rs2[]=new int[100001];//用于记录新链地址
        int num=sc.nextInt();
        int n=sc.nextInt();
        int l1=0,l2=0;
        for(int i=0;i<n;i++)
        {
            int address=sc.nextInt();
            a[address]=sc.nextInt();
            b[address]=sc.nextInt();
        }
        while(num!=-1)
        {
            if(c[Math.abs(a[num])]==0)
            {
                c[Math.abs(a[num])]=1;
                rs1[l1++]=num;
            }
            else
            {
                rs2[l2++]=num;
            }
            num=b[num];
        }
        int i;
        for(i=0;i<l1-1;i++)
        {
            num=rs1[i];
            System.out.printf("%05d %d %05d\n",num,a[num],rs1[i+1]);
        }
        num=rs1[i];
        System.out.printf("%05d %d -1\n",num,a[num]);
        if(l2!=0)
        {
            for(i=0;i<l2-1;i++)
            {
                num=rs2[i];
                System.out.printf("%05d %d %05d\n",num,a[num],rs2[i+1]);
            }
            num=rs2[i];
            System.out.printf("%05d %d -1\n",num,a[num]);
        }
    }
}

Java经典超时!!!